summaryrefslogtreecommitdiff
path: root/dev-util/dmake/dmake-4.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/dmake/dmake-4.12.2.ebuild')
-rw-r--r--dev-util/dmake/dmake-4.12.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/dmake/dmake-4.12.2.ebuild b/dev-util/dmake/dmake-4.12.2.ebuild
new file mode 100644
index 000000000000..9029df2aefed
--- /dev/null
+++ b/dev-util/dmake/dmake-4.12.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Improved make"
+HOMEPAGE="https://github.com/mohawk2/dmake"
+SRC_URI="http://${PN}.apache-extras.org.codespot.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+# test failure, reported upstream at
+# https://code.google.com/a/apache-extras.org/p/dmake/issues/detail?id=1
+RESTRICT="test"
+
+DEPEND="
+ app-arch/unzip
+ sys-apps/groff
+"
+RDEPEND=""
+
+src_prepare() {
+ # make tests executable, bug #404989
+ chmod +x tests/targets-{1..12} || die
+}
+
+src_install () {
+ default
+ newman man/dmake.tf dmake.1
+}