summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-182.ebuild112
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 48175055ec09..0bac569af7c0 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,7 +1,9 @@
DIST diffoscope-177.tar.gz 1590984 BLAKE2B 94daf9528c8fd0ad6ed89bdbee7b21352bf33dcef2ae7e526ea3b1036d92b6fecefcb0da46b7eedf7af1c8bd7995e73b8f0a5104c02f4db534f7bcc465c803aa SHA512 674a5cc364927437a79420b0965eb6958bd09df58a1238ea4d953bb2bc0fbdde75e42817370dd3cdab0bcc59551e1cff70db72298087af551d5dfaee57995811
DIST diffoscope-180.tar.gz 1600542 BLAKE2B 0cc34106f039e0682b32de284b3ce1be90e8629fb4ba18cffa31d7c970a9d18392060f37b201d4ee9ab3f4f65401684c72edf2d00d56827cbaacbfde0ce81d11 SHA512 abf2c514b9f3b074a5b9a6e19f09a474a8ba58e00974a48ebd860cc31547204fb4690224cb752b4248a0674d979bd20c6d4c77ffb912f2b85499d48d90affeb4
DIST diffoscope-181.tar.gz 1602420 BLAKE2B ae5f40b7a687c6425444df816b0583e50a0c86a4c31b44034a365c18e448765587a093794d3aab930b979706655a661a3cd8b398e34604c7f3e556a9f918406d SHA512 de4132b936ce6c79e333ab5c835f4dfe30951fc91b70848f9ecc91cb5323b81a47fa25a6cec562cfd3d059d96809bd85dbe1b37971fffdc15303ac504514759a
+DIST diffoscope-182.tar.gz 1602751 BLAKE2B 0039dd91d5f6653cd2addb0193d9070e53fd785ace64ca11a2ffe80078ff07a43deba6ee4c16f29d9152d18130fc793a48086fba48ce0d60861f0bf71d1c375e SHA512 86333b443c18e6ec809742707d7242deb4977a20e2d864a873519120fb0fe0504a3198cc0f2ff66d6101182bdfd998a96a260a75da710c3ef43a1220c7126897
EBUILD diffoscope-177-r1.ebuild 3325 BLAKE2B b11da425c3c3f5cbf6b6c654bc203c3d6bf56908e2dbdf35d9262a1e5b969655a62aab9aadf7501d6ffcf5c51a7c27a088dca858e81d6b041b72c52d53323da0 SHA512 137eee2580e2693c71fdc72c6cad6499c8be5bc5bb9c3eb302ae95578cbcd15b91a003357eca753392c69aa726797a8e550d7665811370b76fa54dc67bf3a55e
EBUILD diffoscope-180.ebuild 3302 BLAKE2B 63d8be7f8341bc5088ecd613c32fa1b3b60459e17928f820135a60adb4570f3230473a3339db2e984835d13f0c18646ebc5c1495acf1b2ef4504b45171a7df34 SHA512 e988c61c2b60dc92b391ffa66f54673bd09d1e5d96fc8e3273e01a45242e9a12fd2a8387a753207dbadf58307fcdcf3401e3137d8ad8de529da6203f91167451
EBUILD diffoscope-181.ebuild 3302 BLAKE2B 63d8be7f8341bc5088ecd613c32fa1b3b60459e17928f820135a60adb4570f3230473a3339db2e984835d13f0c18646ebc5c1495acf1b2ef4504b45171a7df34 SHA512 e988c61c2b60dc92b391ffa66f54673bd09d1e5d96fc8e3273e01a45242e9a12fd2a8387a753207dbadf58307fcdcf3401e3137d8ad8de529da6203f91167451
+EBUILD diffoscope-182.ebuild 3302 BLAKE2B 63d8be7f8341bc5088ecd613c32fa1b3b60459e17928f820135a60adb4570f3230473a3339db2e984835d13f0c18646ebc5c1495acf1b2ef4504b45171a7df34 SHA512 e988c61c2b60dc92b391ffa66f54673bd09d1e5d96fc8e3273e01a45242e9a12fd2a8387a753207dbadf58307fcdcf3401e3137d8ad8de529da6203f91167451
MISC metadata.xml 2077 BLAKE2B 2f4d188accf1f75c139a388f564ef5130ea8e74e403072871e4b73b848eaf405076bae7190565f374c193cb4f3fd0be16e3c781ac73df1d1cfb36101142b59eb SHA512 683e181724871d636610c7cfa93c714ceddba7e95b80fda8837e04b396f63049307b23b0471cfc19c46de5bd8b6f7bc868412f8f1c817933ac9507e7280b2272
diff --git a/dev-util/diffoscope/diffoscope-182.ebuild b/dev-util/diffoscope/diffoscope-182.ebuild
new file mode 100644
index 000000000000..086eecc95294
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-182.ebuild
@@ -0,0 +1,112 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ )
+"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local exclude=(
+ # test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+
+ # needs triage
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+ )
+ epytest ${exclude[@]/#/--deselect }
+}