summaryrefslogtreecommitdiff
path: root/dev-util/devhelp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/Manifest2
-rw-r--r--dev-util/devhelp/devhelp-40.1.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-util/devhelp/Manifest b/dev-util/devhelp/Manifest
index 5fc3e5976c29..46416e00799f 100644
--- a/dev-util/devhelp/Manifest
+++ b/dev-util/devhelp/Manifest
@@ -1,4 +1,6 @@
AUX 40.0-optional-introspection.patch 1163 BLAKE2B ce50a6bbb920610be1daa723383e1fd464aed84f3d01911e1f85b50adf1f44680518a15e896b351271a3c3ac5500c2fbe148392fe90191f0ed37162faacded88 SHA512 6f874452379b76ee0ef1b402a7bd706e3543cf10b9033e5c5c0d1e153ce8d845e75056d10b1f451fc4ffe2073a7157ab492416d9c76eed44e38d00d919ddbd57
DIST devhelp-40.0.tar.xz 318076 BLAKE2B 05345f422e0ec906855c139306020165277daefea2c85229092be57c98f96459c33ab0fdf847a7135fa1b329c76edea71f7da0342c6673a828efe26298d26bdf SHA512 b8dd5fbb12558845f7f5794dad56ef0ffc1dbd60d5a6a28029dc8acea241e8deb1b68cd0abe9d620a512931a1c5f6db12fc594cd4597758c8d4904fb64e6ade7
+DIST devhelp-40.1.tar.xz 318172 BLAKE2B 83f71b66538b700790961e3dd3c7c7a75199f499a1fb32eb01e62fd5d11e72ae4e860bcfab2615bd4d417d5c57b89dad7eb2f1de4930e39e544d42b57a193b97 SHA512 4c541db9a2222dce4064f401c1d0a9f3233e2dbab17206358dfcce360286f69698248d08172fb236a692b125d8cd3a5bb76b6377b01b52c3d096fa4528400acd
EBUILD devhelp-40.0.ebuild 1781 BLAKE2B ed190ff0984a757e3a3cfcbc7d9ac3fbd5eb97d516bbfa1c21931f91334364148fdb76bb436af362f1424a0981861497946fa77a1871db735a8bdc5ede77b52a SHA512 fe83470f41a3530c4ef091a63cd0de81cb8b9536a6f3f702427867e099e76a32ba977e4287e77647331fa1e30518990bd7a47496f87ef1d9d8d8f4692f166bef
+EBUILD devhelp-40.1.ebuild 1783 BLAKE2B 7a5291bbba4a6af01558d5664f4438d0bbf699a11d30fa9135f910ed4480f7b240d7b1030e82d34acb560a16ab8c7102f16adfdc51c6c963cceee35e857ad176 SHA512 0679d8dec8786ab3e92094fef36949e808aa8ccbb62d3068e88641c744cdb1afec949bd547e6814724a30949b167b5aca5f470221fd195c9a5ff80b317b59cbf
MISC metadata.xml 337 BLAKE2B b031370d8a469a93790b021e5d5f1bbd368ad0c13b144e4fb593d0abbe04d2408f6a7083ae1a1580ef5fdeaf26c59bcbcfcc0d5731f2fd42bde769cf1fb1ece2 SHA512 76931a5e5bff4c6f32aa55e27ff6ef6e320f79c21f1e3c3b3af4733dc0c141a7b782dfa38227fca4d6d50b763dcc3fd191581862ada051951b3185c596ca6753
diff --git a/dev-util/devhelp/devhelp-40.1.ebuild b/dev-util/devhelp/devhelp-40.1.ebuild
new file mode 100644
index 000000000000..fc32178168aa
--- /dev/null
+++ b/dev-util/devhelp/devhelp-40.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="An API documentation browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0"
+SLOT="0/3-6" # subslot = 3-(libdevhelp-3 soname version)
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="+gedit gtk-doc +introspection"
+REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=net-libs/webkit-gtk-2.24:4[introspection?]
+ >=gui-libs/amtk-5.0:5
+ gnome-base/gsettings-desktop-schemas
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ gedit? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[introspection(+),python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ dev-util/itstool
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/40.0-optional-introspection.patch
+)
+
+pkg_setup() {
+ use gedit && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dflatpak_build=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dplugin_emacs=true
+ $(meson_use gedit plugin_gedit)
+ -Dplugin_vim=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use gedit && python_optimize "${ED}"/usr/$(get_libdir)/gedit/plugins
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}