summaryrefslogtreecommitdiff
path: root/dev-util/dejagnu/dejagnu-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/dejagnu/dejagnu-1.6.ebuild')
-rw-r--r--dev-util/dejagnu/dejagnu-1.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/dejagnu/dejagnu-1.6.ebuild b/dev-util/dejagnu/dejagnu-1.6.ebuild
new file mode 100644
index 000000000000..3c1d667317da
--- /dev/null
+++ b/dev-util/dejagnu/dejagnu-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Framework for testing other programs"
+HOMEPAGE="https://www.gnu.org/software/dejagnu/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/tcl
+ dev-tcltk/expect"
+
+src_test() {
+ # if you dont have dejagnu emerged yet, you cant
+ # run the tests ... crazy aint it :)
+ type -p runtest || return 0
+ emake check
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}