summaryrefslogtreecommitdiff
path: root/dev-util/cppunit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/Manifest4
-rw-r--r--dev-util/cppunit/cppunit-1.13.1.ebuild58
-rw-r--r--dev-util/cppunit/cppunit-1.13.2-r2.ebuild66
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-util/cppunit/Manifest b/dev-util/cppunit/Manifest
index 52ba4cbee899..a80bef95b58f 100644
--- a/dev-util/cppunit/Manifest
+++ b/dev-util/cppunit/Manifest
@@ -1,4 +1,8 @@
+DIST cppunit-1.13.1.tar.gz 841334 BLAKE2B 4c27d666900e46fb2146f939ce7f5f2b036c971616c0642c3f601f349b14d7bb8d3a389fc93f31fe133b4df37551d0381e76bbcfb1785a4becf30db57726ca56 SHA512 3b588dd0ed35eca1dec1a7dcf21da40307b1da26d8e29a26a2fcb16cd4ba7e4dfdf58b6c3d537af2ad127c418b11ba62a1168312abb200d5aab8cb8475766a9d
+DIST cppunit-1.13.2.tar.gz 953596 BLAKE2B 205a631dde2cdd2b543be3e39c66331499f7f76e734bf227e94958dc1a4ce57e3ec11a3d555ddf3b8bb8a55b34478b74ac766147630478a53af0c96b606b43e6 SHA512 8f4be569f321d577cec31931f49f4df143bc94e283605509b6ea50c60690aa91a2aed940e7eebd4b2413a4218f9a6c3978d312d8e587eab040283c6563846ecd
DIST cppunit-1.14.0.tar.gz 959716 BLAKE2B 581e3b73d6d152c249005ddf267100443e6c9cba12c52c43e9d6f81096b9cd13c3686fa2f73ebaf28c31193e41dbfd5d919dfb0143b190881345da65a5b7f86d SHA512 4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e
+EBUILD cppunit-1.13.1.ebuild 1519 BLAKE2B b947d09d79ae72338dcd884cea61ebfd4540f2cb8cdba41b116b6d73f4c28982b29676ac8904628ff75da8a4b1c9aff5d4e58190c4da05d90087e81040b03005 SHA512 828a553548f581e0de5c161e1c113943a87b4ce7a53389e6d0bdee808ac4acf75acef2c393a41cf142aaeccef1732f618a99500a91dc400a9c00f43f2b1362b5
+EBUILD cppunit-1.13.2-r2.ebuild 1723 BLAKE2B 669773bfcd5343b03f4b23f3a39299d405ae686cc7c077f82d73c6b9e2778628648614b206e0ff81260c0b05237053a84b0f20dfa5ed40b4599fd9434b8d2b0e SHA512 97e501aabb9c2ed2589b3f7566b0990955816ecf7d052d6765d1e219677c08a8c75eb2f4486ab7090d51ac1123cdd0a67363b2dad3cd3891fb002405405ab2d4
EBUILD cppunit-1.14.0.ebuild 1722 BLAKE2B ea258759c776266c6db28b138f60b31c60c628be29ccbb23afbe6dea75c0137d8c43f12742f0df12516e0016d5c62979c7170d975337b6b27cb3d4e7871b139a SHA512 713f4a0b7ed0c565744af7512cc0772976b1dbba81b46cb2aebe230a6497f5e75ed59f5d518de6578150e6d54e62392f43bffa5c554ef84b1c0d815989313097
EBUILD cppunit-9999.ebuild 1736 BLAKE2B 5bde8ba9a2298f612f2396f3f3de5893ebf5ae7868eb74e1ab78bfe9e8d739560d97f9d3d10c8abc4a216f768360ad307490ac008566161037a231e99089818a SHA512 38b35d01aa20d7e1c28832403a002b174ba44b656b5ba0f400972907b10bef5e94cc88292dd442aa2c59881e46fb0b8c98bad5d8cbaec93b29a3b7b38cfd6afb
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-util/cppunit/cppunit-1.13.1.ebuild b/dev-util/cppunit/cppunit-1.13.1.ebuild
new file mode 100644
index 000000000000..3384ff90fa8d
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.13.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+[[ ${PV} = 9999 ]] && inherit git-2 autotools
+inherit eutils flag-o-matic
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
+[[ ${PV} = 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} = 9999 ]] || \
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ media-gfx/graphviz
+ )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
+
+src_prepare() {
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc dot) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}
diff --git a/dev-util/cppunit/cppunit-1.13.2-r2.ebuild b/dev-util/cppunit/cppunit-1.13.2-r2.ebuild
new file mode 100644
index 000000000000..9c300614235f
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.13.2-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+[[ ${PV} = 9999 ]] && inherit git-r3 autotools
+inherit eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
+[[ ${PV} = 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} = 9999 ]] || \
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ media-gfx/graphviz
+ )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/cppunit-config
+)
+
+src_prepare() {
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable doc doxygen) \
+ $(multilib_native_use_enable doc dot) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-silent-rules
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}