summaryrefslogtreecommitdiff
path: root/dev-util/confix/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/confix/files')
-rw-r--r--dev-util/confix/files/2.1.0/jni-hpux.patch10
-rw-r--r--dev-util/confix/files/2.3.0/exeext.patch20
-rw-r--r--dev-util/confix/files/2.3.0/ext-ac-archive.patch35
-rw-r--r--dev-util/confix/files/2.3.0/local-libs-first.patch39
-rw-r--r--dev-util/confix/files/2.3.0/new-automake.patch12
-rw-r--r--dev-util/confix/files/confix-2.3.5-nodist-shar.patch44
-rw-r--r--dev-util/confix/files/confix-2.3.5-support-no_undefined.patch213
7 files changed, 373 insertions, 0 deletions
diff --git a/dev-util/confix/files/2.1.0/jni-hpux.patch b/dev-util/confix/files/2.1.0/jni-hpux.patch
new file mode 100644
index 000000000000..bd1b626e7bc2
--- /dev/null
+++ b/dev-util/confix/files/2.1.0/jni-hpux.patch
@@ -0,0 +1,10 @@
+--- Confix-2.0.0pre20/share/confix/autoconf-archive/m4src/ac_jni_include_dir.m4.orig 2007-02-07 21:16:20.000000000 +0100
++++ Confix-2.0.0pre20/share/confix/autoconf-archive/m4src/ac_jni_include_dir.m4 2007-02-07 21:16:34.000000000 +0100
+@@ -67,6 +67,7 @@
+ mingw*) _JNI_INC_SUBDIRS="win32";;
+ cygwin*) _JNI_INC_SUBDIRS="win32";;
+ interix*) _JNI_INC_SUBDIRS="win32";;
++hpux*) _JNI_INC_SUBDIRS="hp-ux";;
+ *) _JNI_INC_SUBDIRS="genunix";;
+ esac
+
diff --git a/dev-util/confix/files/2.3.0/exeext.patch b/dev-util/confix/files/2.3.0/exeext.patch
new file mode 100644
index 000000000000..98576f5c9f8b
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/exeext.patch
@@ -0,0 +1,20 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/makefile_am.py confix-9999/libconfix/plugins/automake/makefile_am.py
+--- confix-9999.orig/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:20:42.106291175 +0100
++++ confix-9999/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:23:39.562354663 +0100
+@@ -472,7 +472,15 @@
+
+ # register automatic tests and set their environment
+
+- tests = self.dir_primary('check', 'PROGRAMS') + \
++ test_tmp = self.dir_primary('check', 'PROGRAMS')
++ count = 0
++ for prog in test_tmp:
++ prog += "$(EXEEXT)"
++ test_tmp[count] = prog
++ count += 1
++ pass
++
++ tests = test_tmp + \
+ self.dir_primary('check', 'SCRIPTS')
+ if len(tests):
+ lines.extend(makefile.List(name='TESTS', values=tests, mitigate=True).lines())
diff --git a/dev-util/confix/files/2.3.0/ext-ac-archive.patch b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
new file mode 100644
index 000000000000..32122c95bfe2
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
@@ -0,0 +1,35 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/bootstrap.py confix-9999/libconfix/plugins/automake/bootstrap.py
+--- confix-9999.orig/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:25:27.962172020 +0100
++++ confix-9999/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:27:14.780605001 +0100
+@@ -16,7 +16,7 @@
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ # USA
+
+-import autoconf_archive
++#import autoconf_archive
+ import kde_hack
+
+ from libconfix.core.utils.error import Error
+@@ -29,7 +29,7 @@
+
+ def bootstrap(packageroot, use_kde_hack, argv0, path=None):
+ aclocal_incdirs = []
+- aclocal_incdirs.append(autoconf_archive.include_path(argv0))
++ #aclocal_incdirs.append(autoconf_archive.include_path(argv0))
+
+ # if package's configure.ac looks like using libtool, then we
+ # assume that the package must be libtoolize'd.
+diff -ru confix-9999.orig/setup.py confix-9999/setup.py
+--- confix-9999.orig/setup.py 2009-10-30 13:25:27.965360137 +0100
++++ confix-9999/setup.py 2009-10-30 13:26:47.822129311 +0100
+@@ -41,8 +41,8 @@
+ return result
+
+ datafiles = []
+-datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
+-datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
+
+ # scripts to put in the auxdir.
+ datafiles.extend([('share/confix/kde-hack',
diff --git a/dev-util/confix/files/2.3.0/local-libs-first.patch b/dev-util/confix/files/2.3.0/local-libs-first.patch
new file mode 100644
index 000000000000..29d4a7a1cc9d
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/local-libs-first.patch
@@ -0,0 +1,39 @@
+With libtool, link local libraries with /path/to/libfile.la instead of libpath,
+to avoid encoding local libpath into installed la-file.
+These also have to be linked first, to avoid finding already installed
+libraries of previous versions during libtool-relink.
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py Confix-2.3.0/libconfix/plugins/automake/c/out_c.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py 2010-07-06 12:55:59.286540943 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/c/out_c.py 2010-07-06 13:01:23.574428852 +0200
+@@ -411,6 +411,8 @@
+ """
+ assert isinstance(linked_builder, LinkedBuilder)
+
++ local_paths = []
++ local_libraries = []
+ native_paths = []
+ native_libraries = []
+ external_linkline = []
+@@ -424,8 +426,11 @@
+
+ for bi in native_libs_to_use:
+ if isinstance(bi, BuildInfo_CLibrary_NativeLocal):
+- native_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
+- native_libraries.append('-l'+bi.basename())
++ if self.__use_libtool:
++ local_libraries.append('/'.join(['$(top_builddir)']+bi.dir()+['lib'+bi.basename()+'.la']))
++ else:
++ local_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
++ local_libraries.append('-l'+bi.basename())
+ continue
+ if isinstance(bi, BuildInfo_CLibrary_NativeInstalled):
+ using_installed_library = True
+@@ -447,7 +452,7 @@
+ external_linkline.extend(elem)
+ pass
+
+- return native_paths + native_libraries + external_linkline
++ return local_paths + local_libraries + native_paths + native_libraries + external_linkline
+
+ def external_libpath(self):
+ """ For unit tests only. """
diff --git a/dev-util/confix/files/2.3.0/new-automake.patch b/dev-util/confix/files/2.3.0/new-automake.patch
new file mode 100644
index 000000000000..d6f24a4cae81
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/new-automake.patch
@@ -0,0 +1,12 @@
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py Confix-2.3.0/libconfix/plugins/automake/out_automake.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py 2010-07-12 13:15:49.254867387 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/out_automake.py 2010-07-12 13:17:29.755908602 +0200
+@@ -170,7 +170,7 @@
+
+
+ # our minimum required automake version is 1.9
+- self.makefile_am().add_automake_options('1.9')
++ # self.makefile_am().add_automake_options('1.9')
+
+
+ # enable dist'ing in the following formats
diff --git a/dev-util/confix/files/confix-2.3.5-nodist-shar.patch b/dev-util/confix/files/confix-2.3.5-nodist-shar.patch
new file mode 100644
index 000000000000..bccc437de44c
--- /dev/null
+++ b/dev-util/confix/files/confix-2.3.5-nodist-shar.patch
@@ -0,0 +1,44 @@
+------------------------------------------------------------------------
+r961 | mhaubi | 2017-09-26 15:34:00 +0200 (Tue, 26 Sep 2017) | 1 line
+
+drop 'dist-shar', deprecated by newer automake
+
+Index: doc/confix.texi
+===================================================================
+#--- doc/confix.texi (revision 960)
+#+++ doc/confix.texi (working copy)
+#@@ -992,9 +992,6 @@
+ @code{dist-bzip2} creates a @file{.tar.bz2} distribution.
+
+ @item
+-@code{dist-shar} creates a shell archive distribution.
+-
+-@item
+ @code{dist-zip} create a zip file (popular on Windows).
+
+ @item
+Index: libconfix/plugins/automake/out_automake.py
+===================================================================
+--- libconfix/plugins/automake/out_automake.py (revision 960)
++++ libconfix/plugins/automake/out_automake.py (working copy)
+@@ -175,7 +175,6 @@
+
+ # enable dist'ing in the following formats
+ self.makefile_am().add_automake_options('dist-bzip2')
+- self.makefile_am().add_automake_options('dist-shar')
+ self.makefile_am().add_automake_options('dist-zip')
+
+
+Index: libconfix/plugins/automake/tests/output.py
+===================================================================
+--- libconfix/plugins/automake/tests/output.py (revision 960)
++++ libconfix/plugins/automake/tests/output.py (working copy)
+@@ -146,7 +146,7 @@
+
+ self.failUnless('1.9' in rootdir_automake_builder.makefile_am().automake_options())
+ self.failUnless('dist-bzip2' in rootdir_automake_builder.makefile_am().automake_options())
+- self.failUnless('dist-shar' in rootdir_automake_builder.makefile_am().automake_options())
++ self.failUnless('dist-shar' not in rootdir_automake_builder.makefile_am().automake_options())
+ self.failUnless('dist-zip' in rootdir_automake_builder.makefile_am().automake_options())
+ self.failUnless(const.CONFIX2_DIR in rootdir_automake_builder.makefile_am().extra_dist())
+ self.failUnless(const.CONFIX2_PKG in rootdir_automake_builder.makefile_am().extra_dist())
diff --git a/dev-util/confix/files/confix-2.3.5-support-no_undefined.patch b/dev-util/confix/files/confix-2.3.5-support-no_undefined.patch
new file mode 100644
index 000000000000..a6ffaae89c98
--- /dev/null
+++ b/dev-util/confix/files/confix-2.3.5-support-no_undefined.patch
@@ -0,0 +1,213 @@
+------------------------------------------------------------------------
+r960 | mhaubi | 2017-09-26 14:51:18 +0200 (Tue, 26 Sep 2017) | 10 lines
+
+add 'has_undefined_symbols' property for libraries
+
+Windows does not support undefined symbols in shared libraries,
+so libtool refuses to create DLLs without the -no-undefined flag.
+
+Adding explicit HAS_UNDEFINED_SYMBOLS(False) api call per library,
+and the optional (has_undefined_symbols=False) argument to AutoC().
+
+For backwards compatibility, default is (has_undefined_symbols=True).
+
+------------------------------------------------------------------------
+Index: libconfix/plugins/automake/c/out_c.py
+===================================================================
+--- libconfix/plugins/automake/c/out_c.py (revision 959)
++++ libconfix/plugins/automake/c/out_c.py (revision 960)
+@@ -487,6 +487,9 @@
+ elif b.default_version() is not None:
+ automake_output_builder.makefile_am().add_compound_ldflags(automakelibname, '-release '+b.default_version())
+ pass
++ if b.has_undefined_symbols() is False:
++ automake_output_builder.makefile_am().add_compound_ldflags(automakelibname, '-no-undefined')
++ pass
+ pass
+ else:
+ automake_output_builder.configure_ac().add_paragraph(
+Index: libconfix/plugins/c/clusterer.py
+===================================================================
+--- libconfix/plugins/c/clusterer.py (revision 959)
++++ libconfix/plugins/c/clusterer.py (revision 960)
+@@ -33,7 +33,7 @@
+ import types
+
+ class CClustererSetup(Setup):
+- def __init__(self, linkednamefinder=None):
++ def __init__(self, linkednamefinder=None, has_undefined_symbols=True):
+ assert linkednamefinder is None or isinstance(linkednamefinder, NameFinder)
+ Setup.__init__(self)
+ if linkednamefinder is None:
+@@ -41,10 +41,11 @@
+ else:
+ self.__namefinder = linkednamefinder
+ pass
++ self.__has_undefined_symbols = has_undefined_symbols
+ pass
+
+ def setup(self, dirbuilder):
+- clusterer = CClusterer(namefinder=self.__namefinder)
++ clusterer = CClusterer(namefinder=self.__namefinder, has_undefined_symbols=self.__has_undefined_symbols)
+ dirbuilder.add_builder(clusterer)
+ dirbuilder.add_interface(CClustererInterfaceProxy(clusterer=clusterer))
+ pass
+@@ -51,11 +52,12 @@
+ pass
+
+ class CClusterer(Builder):
+- def __init__(self, namefinder):
++ def __init__(self, namefinder, has_undefined_symbols=True):
+ Builder.__init__(self)
+ self.__namefinder = namefinder
+ self.__libname = None
+ self.__libtool_version_info = None
++ self.__has_undefined_symbols = has_undefined_symbols
+ pass
+
+ def shortname(self):
+@@ -85,6 +87,15 @@
+ pass
+ pass
+
++ def set_has_undefined_symbols(self, has_undefined_symbols):
++ self.__has_undefined_symbols = has_undefined_symbols
++ for builder in self.parentbuilder().iter_builders():
++ if isinstance(builder, LibraryBuilder):
++ builder.set_has_undefined_symbols(has_undefined_symbols)
++ break
++ pass
++ pass
++
+ def enlarge(self):
+ super(CClusterer, self).enlarge()
+
+@@ -163,7 +174,8 @@
+ LibraryBuilder(
+ basename=libname,
+ version=self.__libtool_version_info,
+- default_version=self.package().version()))
++ default_version=self.package().version(),
++ has_undefined_symbols=self.__has_undefined_symbols))
+ for b in itertools.chain(nomain_builders, header_builders):
+ library.add_member(b)
+ pass
+@@ -229,6 +241,13 @@
+ pass
+ self.__clusterer.set_libtool_version_info(version)
+ pass
++
++ def HAS_UNDEFINED_SYMBOLS(self, has_undefined_symbols):
++ if type(has_undefined_symbols) is not types.BooleanType:
++ raise Error("HAS_UNDEFINED_SYMBOLS(): 'has_undefined_symbols' argument must be a boolean")
++ self.__clusterer.set_has_undefined_symbols(has_undefined_symbols)
++ pass
++
+ pass
+
+ class NameFinder:
+Index: libconfix/plugins/c/explicit_iface.py
+===================================================================
+--- libconfix/plugins/c/explicit_iface.py (revision 959)
++++ libconfix/plugins/c/explicit_iface.py (revision 960)
+@@ -104,7 +104,7 @@
+ self.__dirbuilder.add_builder(yacc)
+ return yacc
+
+- def LIBRARY(self, members, basename=None, version=None):
++ def LIBRARY(self, members, basename=None, version=None, undefined_symbols=True):
+ the_basename = basename
+ if the_basename is None:
+ the_basename=LongNameFinder().find_libname(
+@@ -113,7 +113,8 @@
+ pass
+ library = LibraryBuilder(basename=the_basename,
+ version=version,
+- default_version=self.__dirbuilder.package().version())
++ default_version=self.__dirbuilder.package().version(),
++ has_undefined_symbols=undefined_symbols)
+ for m in members:
+ library.add_member(m)
+ pass
+Index: libconfix/plugins/c/library.py
+===================================================================
+--- libconfix/plugins/c/library.py (revision 959)
++++ libconfix/plugins/c/library.py (revision 960)
+@@ -25,7 +25,8 @@
+ def __init__(self,
+ basename,
+ version,
+- default_version):
++ default_version,
++ has_undefined_symbols):
+
+ # library version. passed to libtool as "-version-info
+ # <current>:<revision>:<age>", for example.
+@@ -40,6 +41,7 @@
+ self.__basename = basename
+ self.__version = version
+ self.__default_version = default_version
++ self.__has_undefined_symbols = has_undefined_symbols
+
+ self.__buildinfo_added = False
+
+@@ -82,6 +84,10 @@
+ super(LibraryBuilder, self).force_enlarge()
+ pass
+
++ def set_has_undefined_symbols(self, has_undefined_symbols):
++ self.__has_undefined_symbols = has_undefined_symbols
++ pass
++
+ def version(self):
+ return self.__version
+
+@@ -88,4 +94,7 @@
+ def default_version(self):
+ return self.__default_version
+
++ def has_undefined_symbols(self):
++ return self.__has_undefined_symbols
++
+ pass
+Index: libconfix/plugins/c/setups/default_setup.py
+===================================================================
+--- libconfix/plugins/c/setups/default_setup.py (revision 959)
++++ libconfix/plugins/c/setups/default_setup.py (revision 960)
+@@ -25,8 +25,8 @@
+
+ from libconfix.core.machinery.setup import CompositeSetup
+
+-def make_core_setups(linkednamefinder):
+- return [CClustererSetup(linkednamefinder=linkednamefinder),
++def make_core_setups(linkednamefinder, has_undefined_symbols):
++ return [CClustererSetup(linkednamefinder=linkednamefinder, has_undefined_symbols=has_undefined_symbols),
+ CCreatorSetup(),
+ CommonInterfaceSetup(),
+ RelocatedHeadersSetup(),
+@@ -34,8 +34,9 @@
+
+ class DefaultCSetup(CompositeSetup):
+ def __init__(self,
+- linkednamefinder=None):
+- setups = make_core_setups(linkednamefinder=linkednamefinder)
++ linkednamefinder=None,
++ has_undefined_symbols=True):
++ setups = make_core_setups(linkednamefinder=linkednamefinder, has_undefined_symbols=has_undefined_symbols)
+ setups.append(ImplicitInterfaceSetup())
+ CompositeSetup.__init__(
+ self,
+Index: libconfix/setups/c.py
+===================================================================
+--- libconfix/setups/c.py (revision 959)
++++ libconfix/setups/c.py (revision 960)
+@@ -26,7 +26,7 @@
+ pass
+
+ class AutoC(CompositeSetup):
+- def __init__(self, libnamefinder=None):
+- CompositeSetup.__init__(self, [DefaultCSetup(libnamefinder)])
++ def __init__(self, libnamefinder=None, has_undefined_symbols=True):
++ CompositeSetup.__init__(self, [DefaultCSetup(libnamefinder, has_undefined_symbols=has_undefined_symbols)])
+ pass
+ pass