summaryrefslogtreecommitdiff
path: root/dev-util/conf2struct/conf2struct-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/conf2struct/conf2struct-9999.ebuild')
-rw-r--r--dev-util/conf2struct/conf2struct-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/conf2struct/conf2struct-9999.ebuild b/dev-util/conf2struct/conf2struct-9999.ebuild
index 3ab3bce60c3a..b853d93f1b86 100644
--- a/dev-util/conf2struct/conf2struct-9999.ebuild
+++ b/dev-util/conf2struct/conf2struct-9999.ebuild
@@ -15,14 +15,18 @@ else
SRC_URI="https://github.com/yrutschle/conf2struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
-LICENSE="GPL-2"
+LICENSE="BSD-2"
SLOT="0"
-IUSE="caps pcre systemd tcpd"
+IUSE=""
RDEPEND="dev-libs/libconfig
dev-perl/Conf-Libconfig"
DEPEND="${RDEPEND}"
+src_compile(){
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
src_install(){
emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
}