summaryrefslogtreecommitdiff
path: root/dev-util/cmdtest/cmdtest-0.27.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cmdtest/cmdtest-0.27.ebuild')
-rw-r--r--dev-util/cmdtest/cmdtest-0.27.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/cmdtest/cmdtest-0.27.ebuild b/dev-util/cmdtest/cmdtest-0.27.ebuild
new file mode 100644
index 000000000000..005e6458d635
--- /dev/null
+++ b/dev-util/cmdtest/cmdtest-0.27.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="black box tests Unix command line tools"
+HOMEPAGE="http://liw.fi/cmdtest/"
+SRC_URI="http://code.liw.fi/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/cliapp[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/ttystatus[${PYTHON_USEDEP}]
+"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}