summaryrefslogtreecommitdiff
path: root/dev-util/cligh/cligh-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cligh/cligh-9999.ebuild')
-rw-r--r--dev-util/cligh/cligh-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/cligh/cligh-9999.ebuild b/dev-util/cligh/cligh-9999.ebuild
index 808fce4ea2dd..186acb99add1 100644
--- a/dev-util/cligh/cligh-9999.ebuild
+++ b/dev-util/cligh/cligh-9999.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1 git-r3
DESCRIPTION="Command-line interface to GitHub"
-HOMEPAGE="http://the-brannons.com/software/cligh.html"
+HOMEPAGE="https://the-brannons.com/software/cligh.html"
EGIT_REPO_URI="https://github.com/CMB/${PN}.git"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE=""
-DEPEND="dev-python/PyGithub[${PYTHON_USEDEP}]
+RDEPEND="dev-python/PyGithub[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"