summaryrefslogtreecommitdiff
path: root/dev-util/cgdb/cgdb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cgdb/cgdb-9999.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-9999.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-util/cgdb/cgdb-9999.ebuild b/dev-util/cgdb/cgdb-9999.ebuild
index 191687d3b093..75f88b51bff1 100644
--- a/dev-util/cgdb/cgdb-9999.ebuild
+++ b/dev-util/cgdb/cgdb-9999.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
inherit git-r3
- EGIT_REPO_URI="
- https://github.com/cgdb/cgdb.git
- git@github.com:cgdb/cgdb.git"
else
SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
@@ -23,8 +21,10 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="
- sys-libs/ncurses:0=
+ sys-libs/ncurses:=
sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ sys-devel/gdb"
BDEPEND="
test? (
@@ -32,20 +32,15 @@ BDEPEND="
app-misc/dtach
)"
-RDEPEND="
- ${DEPEND}
- sys-devel/gdb"
-
DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
PATCHES=(
# Bug: #724256
- "${FILESDIR}/${PN}-0.7.1-respect-AR.patch"
+ "${FILESDIR}/${P}-respect-AR.patch"
)
src_prepare() {
default
- cp configure.{init,ac} || die "cp failed"
AT_M4DIR="config" eautoreconf
}