summaryrefslogtreecommitdiff
path: root/dev-util/ccls/ccls-0.20201219.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccls/ccls-0.20201219.ebuild')
-rw-r--r--dev-util/ccls/ccls-0.20201219.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-0.20201219.ebuild b/dev-util/ccls/ccls-0.20201219.ebuild
new file mode 100644
index 000000000000..ac5830184a31
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20201219.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/rapidjson
+ sys-devel/clang:=
+ sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ -DCLANG_LINK_CLANG_DYLIB=1
+ )
+ cmake_src_configure
+}