summaryrefslogtreecommitdiff
path: root/dev-util/cargo-license/cargo-license-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cargo-license/cargo-license-0.3.0.ebuild')
-rw-r--r--dev-util/cargo-license/cargo-license-0.3.0.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/cargo-license/cargo-license-0.3.0.ebuild b/dev-util/cargo-license/cargo-license-0.3.0.ebuild
new file mode 100644
index 000000000000..99618c8b0217
--- /dev/null
+++ b/dev-util/cargo-license/cargo-license-0.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.2.0
+
+EAPI=7
+
+CRATES="
+ansi_term-0.11.0
+ansi_term-0.9.0
+atty-0.2.13
+backtrace-0.3.40
+backtrace-sys-0.1.32
+bitflags-1.2.1
+bstr-0.2.8
+byteorder-1.3.2
+cargo-license-0.3.0
+cargo_metadata-0.9.1
+cc-1.0.48
+cfg-if-0.1.10
+clap-2.33.0
+csv-1.1.1
+csv-core-0.1.6
+failure-0.1.6
+failure_derive-0.1.6
+getopts-0.2.21
+heck-0.3.1
+itoa-0.4.4
+lazy_static-1.4.0
+libc-0.2.66
+memchr-2.2.1
+proc-macro-error-0.2.6
+proc-macro2-1.0.6
+quote-1.0.2
+regex-automata-0.1.8
+rustc-demangle-0.1.16
+ryu-1.0.2
+semver-0.9.0
+semver-parser-0.7.0
+serde-1.0.103
+serde_derive-1.0.103
+serde_json-1.0.44
+strsim-0.8.0
+structopt-0.3.5
+structopt-derive-0.3.5
+syn-1.0.11
+synstructure-0.12.3
+textwrap-0.11.0
+toml-0.4.10
+unicode-segmentation-1.6.0
+unicode-width-0.1.7
+unicode-xid-0.2.0
+vec_map-0.8.1
+winapi-0.3.8
+winapi-i686-pc-windows-gnu-0.4.0
+winapi-x86_64-pc-windows-gnu-0.4.0
+"
+
+inherit cargo
+
+DESCRIPTION="Cargo subcommand to see license of dependencies"
+HOMEPAGE="https://github.com/onur/cargo-license"
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+QA_FLAGS_IGNORED="/usr/bin/cargo-license"
+
+src_install() {
+ cargo_src_install
+ einstalldocs
+}