summaryrefslogtreecommitdiff
path: root/dev-util/cargo-ebuild/cargo-ebuild-0.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cargo-ebuild/cargo-ebuild-0.3.3.ebuild')
-rw-r--r--dev-util/cargo-ebuild/cargo-ebuild-0.3.3.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/dev-util/cargo-ebuild/cargo-ebuild-0.3.3.ebuild b/dev-util/cargo-ebuild/cargo-ebuild-0.3.3.ebuild
new file mode 100644
index 000000000000..536e479ebd74
--- /dev/null
+++ b/dev-util/cargo-ebuild/cargo-ebuild-0.3.3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 2017-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.3.1
+
+EAPI=7
+
+CRATES="
+ ansi_term-0.11.0
+ anyhow-1.0.42
+ atty-0.2.14
+ base-x-0.2.8
+ bitflags-1.2.1
+ bumpalo-3.7.0
+ camino-1.0.5
+ cargo-lock-7.0.1
+ cargo-platform-0.1.1
+ cargo_metadata-0.14.0
+ cfg-if-1.0.0
+ clap-2.33.3
+ const_fn-0.4.8
+ discard-1.0.4
+ either-1.6.1
+ form_urlencoded-1.0.1
+ getrandom-0.2.3
+ heck-0.3.3
+ hermit-abi-0.1.19
+ idna-0.2.3
+ itertools-0.10.1
+ itoa-0.4.7
+ lazy_static-1.4.0
+ libc-0.2.98
+ log-0.4.14
+ matches-0.1.8
+ percent-encoding-2.1.0
+ phf-0.9.0
+ phf_generator-0.9.0
+ phf_macros-0.9.0
+ phf_shared-0.9.0
+ ppv-lite86-0.2.10
+ proc-macro-error-1.0.4
+ proc-macro-error-attr-1.0.4
+ proc-macro-hack-0.5.19
+ proc-macro2-1.0.28
+ quote-1.0.9
+ rand-0.8.4
+ rand_chacha-0.3.1
+ rand_core-0.6.3
+ rand_hc-0.3.1
+ rustc_version-0.2.3
+ ryu-1.0.5
+ semver-0.9.0
+ semver-1.0.4
+ semver-parser-0.7.0
+ serde-1.0.127
+ serde_derive-1.0.127
+ serde_json-1.0.66
+ sha1-0.6.0
+ siphasher-0.3.6
+ standback-0.2.17
+ stdweb-0.4.20
+ stdweb-derive-0.5.3
+ stdweb-internal-macros-0.2.9
+ stdweb-internal-runtime-0.1.5
+ strsim-0.8.0
+ structopt-0.3.22
+ structopt-derive-0.4.15
+ syn-1.0.74
+ textwrap-0.11.0
+ time-0.2.27
+ time-macros-0.1.1
+ time-macros-impl-0.1.2
+ tinyvec-1.3.1
+ tinyvec_macros-0.1.0
+ toml-0.5.8
+ unicode-bidi-0.3.5
+ unicode-normalization-0.1.19
+ unicode-segmentation-1.8.0
+ unicode-width-0.1.8
+ unicode-xid-0.2.2
+ url-2.2.2
+ vec_map-0.8.2
+ version_check-0.9.3
+ wasi-0.10.2+wasi-snapshot-preview1
+ wasm-bindgen-0.2.75
+ wasm-bindgen-backend-0.2.75
+ wasm-bindgen-macro-0.2.75
+ wasm-bindgen-macro-support-0.2.75
+ wasm-bindgen-shared-0.2.75
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-x86_64-pc-windows-gnu-0.4.0
+"
+
+inherit cargo
+
+DESCRIPTION="Generates an ebuild for a package using the in-tree eclasses."
+HOMEPAGE="https://gitweb.gentoo.org/proj/cargo-ebuild.git"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2
+ $(cargo_crate_uris ${CRATES})"
+
+LICENSE="Apache-2.0 Boost-1.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+QA_FLAGS_IGNORED="usr/bin/cargo-ebuild"