summaryrefslogtreecommitdiff
path: root/dev-util/blueprint-compiler
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/blueprint-compiler')
-rw-r--r--dev-util/blueprint-compiler/Manifest4
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild2
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild74
3 files changed, 78 insertions, 2 deletions
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index 5536fca25fe7..1babd29925aa 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1,3 +1,5 @@
DIST blueprint-compiler-v0.12.0.tar.bz2 90521 BLAKE2B 0c54f287c2d9e6869f323981eaff16785aa4fa7b1c600629bccde059205950f70f2202642130500133c69235ce42abfb5b5492a5727da561db9fe6c865939bb8 SHA512 c1f2f1ab02773b8c9c1d92035a51cd3b5c769a129ea028e02b8d2d88a7a9cb44f14edefd0f8718b90313a22134d8cbab4f699942f7049edd3146b41735e68f56
-EBUILD blueprint-compiler-0.12.0.ebuild 1440 BLAKE2B fd09060895854ab2408687b93478f08ba73830796edfc5f32926d8ad17ec04428f5651d6ca39cb4a7b61b8b3dc8409d91f9558bc1f8675c1789d14f93df212aa SHA512 14283514c28949674e318f9ed4cca8dd2fd8e616bc555956663c53de856af9357c145a1270ed75ace1bbe421450a948b44eb80bd8b4eefd29fae4d12f29d9421
+DIST blueprint-compiler-v0.14.0.tar.bz2 95515 BLAKE2B e5e4c721f76a9455d0f53b54e5b981cbd918959c206cad2b6fa47ba3a85bb1bcacb11d65b848cbde01ae32faa6f09c1f80cf6150ee436e359e7b1e9044822bb4 SHA512 3c2c422c6c41c408aff2b4342186e7a20eeb37489aff396d48c936f7a856e9d946f3d6fb6ad64a0fd933bdfc6bce546571d67c95b8f01af591c562d531c246c0
+EBUILD blueprint-compiler-0.12.0.ebuild 1445 BLAKE2B 702652d856a4962b070a5a2f9b84bf02d513500f33adbfd1293e2cd4e3a14f6d6431232e8aa3847c226463e526576a5254b95993df7efce29284a11f394fd056 SHA512 affdbf96a7f35498a733dd31d22d2ec7330621cdfe0421ff04a0e3f9d4efe176685ff129e7e845862f514a1ae467aac1af6be606d09549fff237f82faa79f795
+EBUILD blueprint-compiler-0.14.0.ebuild 1447 BLAKE2B 2815d09f115797304ff10b15c870c8f095b8d109bc929cb480f945ec30689337a0525b94ef635428f702471ca8df7857e1d00629d0b00e0daea95b99dad5ec98 SHA512 c3623d8bd74c24efb732f7a931191b65e9013ff0a0258cb03caad9cbff81cf17afccbd1ab8699edecbaee30ecfa818cbe78ccb8596dd2c7aaafc1db27fe76e39
MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
index 27d6989cbc37..97f831d134de 100644
--- a/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
@@ -19,7 +19,7 @@ else
SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
S="${WORKDIR}/${PN}-v${PV}"
- KEYWORDS="amd64 ~x86"
+ KEYWORDS="amd64 ~arm ~x86"
fi
LICENSE="LGPL-3+"
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild
new file mode 100644
index 000000000000..0627fff78fe8
--- /dev/null
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit meson python-single-r1 virtualx
+
+DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
+HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
+ https://gitlab.gnome.org/jwestman/blueprint-compiler/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
+else
+ SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ KEYWORDS="amd64 ~arm ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/furo[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ )
+"
+
+DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use doc docs)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ use doc && build_sphinx docs
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}/usr/bin"
+ python_optimize
+}