summaryrefslogtreecommitdiff
path: root/dev-tex/pythontex/pythontex-0.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/pythontex/pythontex-0.17.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-0.17.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-tex/pythontex/pythontex-0.17.ebuild b/dev-tex/pythontex/pythontex-0.17.ebuild
deleted file mode 100644
index b593c06bb328..000000000000
--- a/dev-tex/pythontex/pythontex-0.17.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-
-inherit latex-package python-r1
-
-DESCRIPTION="Fast Access to Python from within LaTeX"
-HOMEPAGE="https://github.com/gpoore/pythontex"
-SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LPPL-1.3 BSD"
-KEYWORDS="~amd64 ~ppc ~riscv ~x86"
-IUSE="doc highlighting"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-texlive/texlive-latexextra-2016
- dev-tex/pgf"
-RDEPEND="${DEPEND}
- dev-python/pygments[${PYTHON_USEDEP}]"
-
-TEXMF=/usr/share/texmf-site
-
-src_compile() {
- cd ${PN} || die
- rm ${PN}.sty || die
- VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
-}
-
-src_install() {
- dodoc *rst
- use doc && dodoc ${PN}_quickstart/*pdf ${PN}/*pdf
-
- cd ${PN} || die
-
- installation() {
- python_domodule {de,}${PN}3.py
- python_domodule ${PN}_{engines,utils}.py
- python_doscript {de,}${PN}.py syncpdb.py
- python_optimize
- }
- python_foreach_impl installation
-
- latex-package_src_doinstall sty
-}