summaryrefslogtreecommitdiff
path: root/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dot2tex/dot2tex-2.9.0.ebuild')
-rw-r--r--dev-tex/dot2tex/dot2tex-2.9.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-tex/dot2tex/dot2tex-2.9.0.ebuild b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
deleted file mode 100644
index 6bc236af1bb2..000000000000
--- a/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Graphviz to LaTeX converter"
-HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
-SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="doc examples"
-
-DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
-RDEPEND="
- dev-python/pydot[${PYTHON_USEDEP}]
- media-gfx/graphviz"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx )"
-
-python_compile_all() {
- if use doc ; then
- cd "${S}/docs"
- emake html
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use doc; then
- dohtml -r docs/_build/html/*
- fi
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}