summaryrefslogtreecommitdiff
path: root/dev-tcltk/tktray/tktray-1.3.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tktray/tktray-1.3.9.ebuild')
-rw-r--r--dev-tcltk/tktray/tktray-1.3.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-tcltk/tktray/tktray-1.3.9.ebuild b/dev-tcltk/tktray/tktray-1.3.9.ebuild
new file mode 100644
index 000000000000..85b005ef2865
--- /dev/null
+++ b/dev-tcltk/tktray/tktray-1.3.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils virtualx
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="System Tray Icon Support for Tk on X11"
+HOMEPAGE="https://code.google.com/p/tktray/"
+SRC_URI="https://tktray.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="tcltk"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE="debug threads test"
+
+DEPEND="
+ >=dev-lang/tcl-8.4:0=
+ >=dev-lang/tk-8.4:0=
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.1-ldflags.patch
+}
+
+src_configure() {
+ source /usr/lib/tclConfig.sh
+ CPPFLAGS="-I${TCL_SRC_DIR}/generic ${CPPFLAGS}" \
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_test() {
+ Xemake
+}