summaryrefslogtreecommitdiff
path: root/dev-tcltk/tkdnd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tkdnd')
-rw-r--r--dev-tcltk/tkdnd/Manifest6
-rw-r--r--dev-tcltk/tkdnd/tkdnd-2.2.ebuild40
-rw-r--r--dev-tcltk/tkdnd/tkdnd-2.6.ebuild40
-rw-r--r--dev-tcltk/tkdnd/tkdnd-2.8.ebuild4
4 files changed, 87 insertions, 3 deletions
diff --git a/dev-tcltk/tkdnd/Manifest b/dev-tcltk/tkdnd/Manifest
index e41fab1016de..9b67daa20252 100644
--- a/dev-tcltk/tkdnd/Manifest
+++ b/dev-tcltk/tkdnd/Manifest
@@ -1,3 +1,7 @@
+DIST tkdnd2.2.tar.gz 501708 BLAKE2B 388a488fa6a6f86041182d741e4bb45b3cf86c8feb39de15010dbd21cddb536800cad0df23b5c27afec83bd4550c759534986b24804aefd007f0de4f5ecbf3cf SHA512 96f3b7209d82801b69932531b987cfe2c3367fbaaffd2198afc84bf21643437db8a9958511e31ce2c36896538ff8f8c9237950d0f82b832f7133fb1e5768fd26
+DIST tkdnd2.6-src.tar.gz 180278 BLAKE2B 598bba80e239440eae5e3dade176a015a33f426a387fbd8dcf96fa7b8644665d05cc2e52a86be40e2c40922211b200c484bde7dc69da1b252922ed203740fc87 SHA512 2ce1be9b49c21bc67102575420311c1ec764493315791c8a76313cae6d22846b3049dd85cdc0b2f28592889432b85103b0fa207445f678dbe22f988eb1d6fc87
DIST tkdnd2.8-src.tar.gz 185025 BLAKE2B 3f7c1b728d12c2ad7d7fea82dae1c3f29207b70fd382fb6aa7aa6602602b0a9b5c4604347b9b1aa1faff7c5952d9557046157cb6af4268b56483f7398d4b55e3 SHA512 0cca1783ed4e481565fa23cebc12382f223c8a02f24a2795af3818d56769d265b45e2ce74d2a4a3a8203718bad6426efe37a5382e8376dd6a0820ef81866050e
-EBUILD tkdnd-2.8.ebuild 904 BLAKE2B fcb4a4b846196af1eb40f103c373dd1b2c198942962050535991168b44299b22d7a50f846c8630509a2e686fc93c8b8c9bf28709ded5134b590daf229c3d3d22 SHA512 d8b68152b19d6f0709a296097fe767a3c67de0c4433bfc35331146f764be59b41dec7644918cf92323759ad91bd77f0942a8892507d4d90f4a5e71ba14be955d
+EBUILD tkdnd-2.2.ebuild 903 BLAKE2B 21e057ee7ea04b4dca78168dca2b201aa6e9fc92cba4971940016d511ab6d05aa2edcdc07e0c4d751c8f972a3f094f106b7d644c0b8364b95ac8deafafb93768 SHA512 627a72f61f8a7d8e4192851155943bd001b66aed95b7f30f5e7c48d55d180f0fe3e7352d25d7c63fc9045f526872ad0684a473e66af8179e15a8549ff16db15a
+EBUILD tkdnd-2.6.ebuild 907 BLAKE2B 5fa1e858ad0d9b3dba3c1a5d9374b372c3035d69224432ed2e3a281a406296d2bd97cb862662743b1ec69a2b115ef4d3df0c59ab8322a395921193ea229f54e6 SHA512 d5fd89c87195c02ccdef39cd9a2fcacad964c1ae60e61536525ff7f7c407f7ac4c4111f52b56dbed9c95d8c2b2f861d4f87e818f3c08c16a49bc4e9f74aaecc9
+EBUILD tkdnd-2.8.ebuild 906 BLAKE2B 831a87175ab8616c76dd896d5c59f8c56971ab237bf26d6166daeb6c727c230bf86ef0c905867b80c90355fa5f783154d29d2fc4d558c81ca715327b305c5457 SHA512 508742bba2c8ab9fd4120421c34f801b7d0d4717022eb6be82571ec4108380e81e0781613323f5d3a67811306bb1c38d8278314e3791c85fdf8ae5d1d82fd251
MISC metadata.xml 328 BLAKE2B a8828cf089a520c1cfaa639bc5587d82ceb3681f97ad00a174ceb9331d12cc063ccb0687dd8e53510a1fb2d807153afdcf7a6be7fae1871621fb032c9c8d9e14 SHA512 3130aa488c2f677c91f3b2ba72a2a9e16446865a10f1629ae7e44b810189ceb24cb9cd14d834a71b76609cc9a2e043d8db7560e9446103368084385754cd5045
diff --git a/dev-tcltk/tkdnd/tkdnd-2.2.ebuild b/dev-tcltk/tkdnd/tkdnd-2.2.ebuild
new file mode 100644
index 000000000000..3f608bac2cdf
--- /dev/null
+++ b/dev-tcltk/tkdnd/tkdnd-2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+MY_PN="TkDND"
+
+DESCRIPTION="Extension that adds native drag & drop capabilities to the tk toolkit"
+HOMEPAGE="http://www.ellogon.org/petasis/tcltk-projects/tkdnd/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${MY_PN}%20${PV}/${P/-/}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug threads X"
+
+RESTRICT="test"
+
+DEPEND="dev-lang/tk"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/-/}
+
+src_prepare() {
+ sed \
+ -e 's:-O2::g' \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-pipe::g' \
+ -i configure tclconfig/tcl.m4 || die
+}
+
+src_configure() {
+ local myeconfargs
+ use X && myeconfargs+=( --with-x )
+ use debug && myeconfargs+=( --with-symbols )
+ use threads && myeconfargs+=( --enable-threads )
+ autotools-utils_src_configure
+}
diff --git a/dev-tcltk/tkdnd/tkdnd-2.6.ebuild b/dev-tcltk/tkdnd/tkdnd-2.6.ebuild
new file mode 100644
index 000000000000..77ed496b529b
--- /dev/null
+++ b/dev-tcltk/tkdnd/tkdnd-2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+MY_PN="TkDND"
+
+DESCRIPTION="Extension that adds native drag & drop capabilities to the tk toolkit"
+HOMEPAGE="http://www.ellogon.org/petasis/tcltk-projects/tkdnd/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${MY_PN}%20${PV}/${P/-/}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug threads X"
+
+DEPEND="dev-lang/tk"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/-/}
+
+RESTRICT="test"
+
+src_prepare() {
+ sed \
+ -e 's:-O2::g' \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-pipe::g' \
+ -i configure tclconfig/tcl.m4 || die
+}
+
+src_configure() {
+ local myeconfargs
+ use X && myeconfargs+=( --with-x )
+ use debug && myeconfargs+=( --with-symbols )
+ use threads && myeconfargs+=( --enable-threads )
+ autotools-utils_src_configure
+}
diff --git a/dev-tcltk/tkdnd/tkdnd-2.8.ebuild b/dev-tcltk/tkdnd/tkdnd-2.8.ebuild
index e1855dc6cd88..b7aecb63ebf7 100644
--- a/dev-tcltk/tkdnd/tkdnd-2.8.ebuild
+++ b/dev-tcltk/tkdnd/tkdnd-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${MY_PN}%20${PV}/${P/-/}-src.tar.gz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug threads X"
DEPEND="dev-lang/tk:="