summaryrefslogtreecommitdiff
path: root/dev-tcltk/tkcon/tkcon-2.7.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tkcon/tkcon-2.7.10.ebuild')
-rw-r--r--dev-tcltk/tkcon/tkcon-2.7.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-tcltk/tkcon/tkcon-2.7.10.ebuild b/dev-tcltk/tkcon/tkcon-2.7.10.ebuild
new file mode 100644
index 000000000000..d0d15951af1d
--- /dev/null
+++ b/dev-tcltk/tkcon/tkcon-2.7.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tk GUI console"
+HOMEPAGE="http://tkcon.sourceforge.net/"
+SRC_URI="https://github.com/wjoye/${PN}/archive/v${PV}.tar.gz ->
+ ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-lang/tk:*"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ mv docs/changes.txt CHANGES
+}
+
+src_install() {
+ local tclver="$(echo 'puts $tcl_version' | tclsh)"
+ local instdir=/usr/$(get_libdir)/tcl${tclver}/${PN}$(ver_cut 1-2)
+ dodir ${instdir}
+ cp -pP pkgIndex.tcl tkcon.tcl "${D}"${instdir} || die
+ dodir /usr/bin
+ dosym ${instdir}/tkcon.tcl /usr/bin/tkcon
+ if use doc; then
+ HTML_DOCS=( docs/* )
+ fi
+ einstalldocs
+}