summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclperl/tclperl-3.2-r1.ebuild')
-rw-r--r--dev-tcltk/tclperl/tclperl-3.2-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild b/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild
index 64e82c79a3e1..199adc9af13d 100644
--- a/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild
+++ b/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit flag-o-matic multilib toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Perl package for Tcl"
HOMEPAGE="http://jfontain.free.fr/tclperl.htm"
@@ -20,6 +20,9 @@ DEPEND="
sys-libs/binutils-libs"
RDEPEND="${DEPEND}"
+DOCS=( CHANGES README)
+HTML_DOCS=( tclperl.htm )
+
src_compile() {
append-flags -fPIC
@@ -36,7 +39,5 @@ src_install() {
exeinto /usr/$(get_libdir)/${P}
doexe tclperl.so.${PV}
doexe pkgIndex.tcl
-
- dodoc CHANGES README
- dohtml tclperl.htm
+ einstalldocs
}