summaryrefslogtreecommitdiff
path: root/dev-tcltk/expect-lite/expect-lite-4.9.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/expect-lite/expect-lite-4.9.0-r1.ebuild')
-rw-r--r--dev-tcltk/expect-lite/expect-lite-4.9.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tcltk/expect-lite/expect-lite-4.9.0-r1.ebuild b/dev-tcltk/expect-lite/expect-lite-4.9.0-r1.ebuild
new file mode 100644
index 000000000000..8dfc45a6b2bb
--- /dev/null
+++ b/dev-tcltk/expect-lite/expect-lite-4.9.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Quick and easy command line automation tool built on top of expect"
+HOMEPAGE="https://expect-lite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug examples"
+
+RDEPEND="dev-tcltk/expect
+ debug? ( dev-tcltk/tclx )"
+
+S=${WORKDIR}/${PN}.proj
+
+DOCS=(
+ bashrc ChangeLog README
+)
+
+src_install() {
+ default
+
+ docinto html
+ dodoc -r Docs/*
+
+ dobin ${PN}
+ gunzip man/*.gz
+ doman man/*
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}