summaryrefslogtreecommitdiff
path: root/dev-scheme/racket/racket-8.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/racket/racket-8.2-r1.ebuild')
-rw-r--r--dev-scheme/racket/racket-8.2-r1.ebuild45
1 files changed, 22 insertions, 23 deletions
diff --git a/dev-scheme/racket/racket-8.2-r1.ebuild b/dev-scheme/racket/racket-8.2-r1.ebuild
index 3437a73c8c5f..ebb87fe339c6 100644
--- a/dev-scheme/racket/racket-8.2-r1.ebuild
+++ b/dev-scheme/racket/racket-8.2-r1.ebuild
@@ -19,12 +19,15 @@ LICENSE="
chez? ( Apache-2.0 )
!chez? ( LGPL-3 )
"
-# Bytecode generated by Racket is not compatible between versions
+# Bytecode generated by Racket is not compatible between versions.
+# The bytecode version should be denoted by SLOT, in most cases
+# PV == SLOT but this has to be checked carefully and in cases
+# where we use _p, _pre, etc it will have to be set manually.
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE="X +chez +doc +futures +jit minimal +places +readline +threads"
+IUSE="X +chez +doc +futures +jit minimal +places +threads"
# See bug #809785 re chez/threads
-REQUIRED_USE="futures? ( jit ) chez? ( threads )"
+REQUIRED_USE="futures? ( jit threads ) chez? ( threads ) places? ( threads )"
DEPEND="
!dev-tex/slatex
@@ -39,7 +42,6 @@ DEPEND="
x11-libs/pango[X]
x11-misc/shared-mime-info
)
- readline? ( dev-libs/libedit )
"
RDEPEND="${DEPEND}"
@@ -135,30 +137,27 @@ src_install() {
}
pkg_preinst() {
- # If we are merging the same version (NOT revision!)
- # check if pkg database files exist and do not overwrite them
- local pvr rel
- for pvr in ${REPLACING_VERSIONS}; do
- rel="${pvr%-r*}"
- if [[ "${rel}" == "${PV}" ]]; then
- echo "We are installing the same version: ${rel}"
- local rktd
- for rktd in "${PKGDB[@]}"; do
- if [[ -f "${EROOT}/${rktd}" ]]; then
- einfo "Keeping old file: ${rktd}"
- mv "${ED}"/${rktd} "${ED}"/${rktd}.bak ||
- die "failed to create a backup of ${rktd}"
- cp "${EROOT}"/${rktd} "${ED}"/${rktd} ||
- die "failed to create a copy of ${rktd}"
- fi
- done
- fi
- done
+ # If we are merging the same SLOT check if package
+ # database files exist and do not overwrite them
+ if has_version "${CATEGORY}/${PN}:${SLOT}"; then
+ echo "We are installing the same SLOT: ${SLOT}"
+ local rktd
+ for rktd in "${PKGDB[@]}"; do
+ if [[ -f "${EROOT}/${rktd}" ]]; then
+ einfo "Keeping old file: ${rktd}"
+ mv "${ED}"/${rktd} "${ED}"/${rktd}.bak ||
+ die "failed to create a backup of ${rktd}"
+ cp "${EROOT}"/${rktd} "${ED}"/${rktd} ||
+ die "failed to create a copy of ${rktd}"
+ fi
+ done
+ fi
}
pkg_postinst() {
post_X_update
+ optfeature "readline editing features in REPL" dev-libs/libedit sys-libs/readline
optfeature "generating PDF files using Scribble" dev-texlive/texlive-fontsextra
}