summaryrefslogtreecommitdiff
path: root/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/owl-lisp/owl-lisp-9999.ebuild')
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
new file mode 100644
index 000000000000..c88a667b978e
--- /dev/null
+++ b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional dialect of Scheme"
+HOMEPAGE="https://haltp.org/posts/owl.html"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
+else
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v0.2/owl-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/owl-v${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_compile(){
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
+}
+
+src_install() {
+ einstalldocs
+
+ dobin ./bin/ol
+ newbin ./bin/vm ovm
+
+ doman ./doc/*.1
+}