summaryrefslogtreecommitdiff
path: root/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-colorized/guile-colorized-9999.ebuild')
-rw-r--r--dev-scheme/guile-colorized/guile-colorized-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-scheme/guile-colorized/guile-colorized-9999.ebuild b/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
new file mode 100644
index 000000000000..79eef16351ba
--- /dev/null
+++ b/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Colorized REPL for GNU Guile"
+HOMEPAGE="https://gitlab.com/NalaGinrut/guile-colorized/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/NalaGinrut/${PN}.git"
+else
+ # Latest release (before this commit from 2019) was in 2015
+ COMMIT_SHA="1625a79f0e31849ebd537e2a58793fb45678c58f"
+ SRC_URI="https://gitlab.com/NalaGinrut/${PN}/-/archive/${COMMIT_SHA}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND=">=dev-scheme/guile-2.0.9:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_install() {
+ einstalldocs
+
+ local loadpath=$(guile -c '(display (string-append (car %load-path) "/ice-9"))')
+ mkdir -p "${D}${loadpath}"
+ emake TARGET="${D}${loadpath}" install
+}