summaryrefslogtreecommitdiff
path: root/dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild')
-rw-r--r--dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild b/dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild
index 9a99480a7c48..8bfec2a242da 100644
--- a/dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild
+++ b/dev-scheme/gauche-qdbm/gauche-qdbm-0.2-r1.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="6"
-inherit autotools eutils
+inherit autotools
-MY_P="${P/g/G}"
+MY_P="${P^g}"
DESCRIPTION="QDBM binding for Gauche"
HOMEPAGE="http://sourceforge.jp/projects/gauche/"
-SRC_URI="mirror://sourceforge.jp/gauche/6988/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge.jp/${PN%-*}/6988/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~sparc x86"
+KEYWORDS="~amd64 ~ia64 ~sparc x86"
IUSE=""
RDEPEND="dev-scheme/gauche
@@ -21,8 +21,13 @@ RDEPEND="dev-scheme/gauche
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gauche-package.patch
+ "${FILESDIR}"/${PN}-test.patch
+ "${FILESDIR}"/${PN}-undefined-reference.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-gauche-package.diff
- epatch "${FILESDIR}"/${P}-undefined-reference.diff
+ default
eautoreconf
}