summaryrefslogtreecommitdiff
path: root/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre20210518.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/gauche-gtk/gauche-gtk-0.6_pre20210518.ebuild')
-rw-r--r--dev-scheme/gauche-gtk/gauche-gtk-0.6_pre20210518.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre20210518.ebuild b/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre20210518.ebuild
new file mode 100644
index 000000000000..d585ddc55762
--- /dev/null
+++ b/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre20210518.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools vcs-snapshot
+
+MY_P="${PN^g}2-${PV}"
+EGIT_COMMIT="0220722c44ef85f2e1b9b14745702c1b923258e8"
+
+DESCRIPTION="GTK2 binding for Gauche"
+HOMEPAGE="https://practical-scheme.net/gauche/"
+SRC_URI="https://github.com/shirok/${PN^g}2/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+RESTRICT="test"
+
+RDEPEND="dev-scheme/gauche:=
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoconf
+}
+
+src_compile() {
+ emake stubs
+ emake
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc examples/*.scm
+ # install gtk-tutorial
+ docinto examples/gtk-tutorial
+ dodoc examples/gtk-tutorial/*
+ fi
+}