summaryrefslogtreecommitdiff
path: root/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild')
-rw-r--r--dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild b/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
index dee6dc5c4eeb..4fff4bfd6313 100644
--- a/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
+++ b/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit elisp-common toolchain-funcs
+inherit elisp-common flag-o-matic toolchain-funcs
MY_PV=${PV/_p/-} # e.g.: 4.4c_p4 -> 4.4c-4
MY_P="${PN}-${MY_PV}"
@@ -71,6 +71,17 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/858248
+ #
+ # The code has various issues that make it look quite worrying to enable
+ # LTO, so I wouldn't risk it even if upstream fixes this one. Cannot even
+ # test compile the package due to bug #870481, bug #911667
+ #
+ # It is also impossible to test from git if any of these are fixed, since
+ # you need a working version in order to compile from git.
+ filter-lto
+
tc-export AR AS CC CPP CXX LD
export CFLAGS
export LDFLAGS