summaryrefslogtreecommitdiff
path: root/dev-ruby/xdr/xdr-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/xdr/xdr-3.0.0.ebuild')
-rw-r--r--dev-ruby/xdr/xdr-3.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/xdr/xdr-3.0.0.ebuild b/dev-ruby/xdr/xdr-3.0.0.ebuild
new file mode 100644
index 000000000000..2923a56ad05e
--- /dev/null
+++ b/dev-ruby/xdr/xdr-3.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Read/write XDR encoded data structures"
+HOMEPAGE="https://github.com/stellar/ruby-xdr"
+
+LICENSE="Apache-2.0"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/activemodel-5.2.0:*
+ >=dev-ruby/activesupport-5.2.0:*"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/pry/ s:^:#:' spec/spec_helper.rb || die
+}