summaryrefslogtreecommitdiff
path: root/dev-ruby/wisper/wisper-2.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/wisper/wisper-2.0.1-r1.ebuild')
-rw-r--r--dev-ruby/wisper/wisper-2.0.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/wisper/wisper-2.0.1-r1.ebuild b/dev-ruby/wisper/wisper-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..57f12cde852b
--- /dev/null
+++ b/dev-ruby/wisper/wisper-2.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A micro library providing objects with Publish-Subscribe capabilities"
+HOMEPAGE="https://github.com/krisleech/wisper"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' spec/spec_helper.rb || die
+}