summaryrefslogtreecommitdiff
path: root/dev-ruby/webrobots/webrobots-0.1.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/webrobots/webrobots-0.1.2-r3.ebuild')
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/webrobots/webrobots-0.1.2-r3.ebuild b/dev-ruby/webrobots/webrobots-0.1.2-r3.ebuild
new file mode 100644
index 000000000000..8868c403f5b3
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock dev-ruby/vcr )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}