summaryrefslogtreecommitdiff
path: root/dev-ruby/tzinfo/tzinfo-1.2.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-1.2.9.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.9.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.9.ebuild
new file mode 100644
index 000000000000..f11f1dc94154
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-1.2.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="https://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.1:0"
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Avoid taint tests that throw SecurityErrors on newer ruby versions.
+ sed -i -e '/_info_tainted/askip"SecurityError"' test/tc_ruby_data_source.rb || die
+}