summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-which
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tty-which')
-rw-r--r--dev-ruby/tty-which/Manifest3
-rw-r--r--dev-ruby/tty-which/metadata.xml11
-rw-r--r--dev-ruby/tty-which/tty-which-0.4.1.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/tty-which/Manifest b/dev-ruby/tty-which/Manifest
new file mode 100644
index 000000000000..07ec1870f7c0
--- /dev/null
+++ b/dev-ruby/tty-which/Manifest
@@ -0,0 +1,3 @@
+DIST tty-which-0.4.1.gem 11264 BLAKE2B 540249aaeaa5458fef3572413cf673e04765c1ad41971ac3f9bd930a42855459db6c6f8f47c90ee1021993161db6a399ba6edd0384da7db91da999550d3e733b SHA512 e48b284abb3e4177b9f04acec5202a70d3fcaa2d477444c5a9d9920ac00eb192656bc48ca33d72c26845b415a0a90e907dab1dd35608b62bc8e4b1b1b25af51c
+EBUILD tty-which-0.4.1.ebuild 504 BLAKE2B e4c9fc62b162655cdead13e5a499ffd5dd92727890245a10bde55eb951910426da783ca3018bc17546e210f8374e0eb77d80e64fe620a860f6ae785b061c51aa SHA512 157233a369734d3a000228f13b9b3993d2cb70b68b973ce89e099bae68abd7c0f843f28c2a894d14607826c9189962f497822d49b33f61ba1c99bdf461d2955e
+MISC metadata.xml 337 BLAKE2B 123637d7c276f3090c739e2a3823bb32dda76b1d375d81da3b7577c597a5358957381f5bfeb0379abef336ec70572a3cbfd04adf1a279a51e1783a7ade883601 SHA512 44af181aeb529b6fcbc3d5f07dcfb88b6b7d161f0d6be57be3c09a2d22a9cdc32b0c281f4336efa645daa7951799387ab899765e33823f34138b29e979887ae2
diff --git a/dev-ruby/tty-which/metadata.xml b/dev-ruby/tty-which/metadata.xml
new file mode 100644
index 000000000000..5fd42b5104ca
--- /dev/null
+++ b/dev-ruby/tty-which/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piotrmurach/tty-which</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-which/tty-which-0.4.1.ebuild b/dev-ruby/tty-which/tty-which-0.4.1.ebuild
new file mode 100644
index 000000000000..74bbc5701956
--- /dev/null
+++ b/dev-ruby/tty-which/tty-which-0.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Platform independent implementation of Unix which command"
+HOMEPAGE="https://github.com/piotrmurach/tty-which"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}