summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-which
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tty-which')
-rw-r--r--dev-ruby/tty-which/Manifest2
-rw-r--r--dev-ruby/tty-which/tty-which-0.5.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/tty-which/Manifest b/dev-ruby/tty-which/Manifest
index 8c49eddf1978..f9dcb0f363de 100644
--- a/dev-ruby/tty-which/Manifest
+++ b/dev-ruby/tty-which/Manifest
@@ -1,3 +1,5 @@
DIST tty-which-0.4.2.tar.gz 9820 BLAKE2B 07ac2aa7a3e42127f456045fbdb92db2ea9834b08e0fccbe81767e01817ec2bf7304fb8a41408b0c4da8ecba3caf8bc236de9cb5637c6f197fe3835d0e9b231e SHA512 573b4ed1bfd4dd66dc3337d076a6559bda57b76c95c75f1aeef8bb6d4e0c81ef72057f5ef0521a10afb2a550b8850e6311aaa56ef2499146221f33403621ee54
+DIST tty-which-0.5.0.tar.gz 11560 BLAKE2B 0b8d821168759ff744ded5a5d7b0864303ed71510dd233b39b6f12fe42f044c4fb48da8f9b0cb16875ae9cce5c66060af8cff858aaa88bdaddfc971886f2ce8b SHA512 a5be30dc857eed2aa8ce81f1c62467451760482b1f51f1c0654c57001a9ab828d31b22b35cd9e37ea2fe91a7514a1a15107b5fc948a561a2ee4e58e0748bacd3
EBUILD tty-which-0.4.2.ebuild 1063 BLAKE2B eecd3cdc80b1ce80e9113fad77381b0d4df8c3c3e54f92f82e72383a4578e98ee60c3d552c51355a126193774623de5c24cb2caeaba503e9ac6c51b689c48a5a SHA512 3c580330845686950781a25c42ebca1c2ae5e0e5fad7eb3ffa15dbdbe743fb61eee7ea9d899210731b6813f74b1125561aed40a0e32e83b04dd3e1c6b45352d3
+EBUILD tty-which-0.5.0.ebuild 1056 BLAKE2B fef23344c3362d844790943d92224da4cfb506e70f2a32e6f8a395df86eb2e9090d763226d341ddf7e8943f56f85630a2fad2d51919abe0b0520d49937d4c831 SHA512 279c2804c5eccf70313e27f2f2acc88c81af410c1f66010a1c57c1261eb700e09d4b36e8c512a146b626e80011daacda85b240fee44c1205710fb5b0af286747
MISC metadata.xml 337 BLAKE2B 8a91aeaf1cd2959f969f49390d9318bf6613ef6154878d396b5056071657ad478334c527832aa0db276d092e3075ea57e54581918a05d278eb9dda32c414f98c SHA512 57de9c2bb03ea22da8686927fbfda138dba784099c225b4c845405c724e4e44f9c8d05c0d59cf1d5503c5c36aa8db5717bd1df65127591fd56c460ff65d4d43d
diff --git a/dev-ruby/tty-which/tty-which-0.5.0.ebuild b/dev-ruby/tty-which/tty-which-0.5.0.ebuild
new file mode 100644
index 000000000000..2bd6b2425e01
--- /dev/null
+++ b/dev-ruby/tty-which/tty-which-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-which.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Platform independent implementation of Unix which command"
+HOMEPAGE="https://github.com/piotrmurach/tty-which"
+SRC_URI="https://github.com/piotrmurach/tty-which/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix running specs without bundler, fixed upstream
+ sed -e 's/receive(:join)$/receive(:join).and_call_original/' \
+ -e '96iallow(::File).to receive(:join).and_call_original' \
+ -e '115iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/which_spec.rb || die
+ sed -e '5iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/executable_file_spec.rb || die
+}