summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-prompt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tty-prompt')
-rw-r--r--dev-ruby/tty-prompt/Manifest3
-rw-r--r--dev-ruby/tty-prompt/metadata.xml11
-rw-r--r--dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/tty-prompt/Manifest b/dev-ruby/tty-prompt/Manifest
new file mode 100644
index 000000000000..3714a72940f4
--- /dev/null
+++ b/dev-ruby/tty-prompt/Manifest
@@ -0,0 +1,3 @@
+DIST tty-prompt-0.19.0.gem 71680 BLAKE2B 67da3c428fa5ab602fa4735d06115ba5bab53f06d43109fa06810e538cafae5486767f41927fc77616e608278a0f955659734704c9536b40e87682e6f0e5718b SHA512 958263a7b3b7cfbac2877d81878b324fe53bc258be36749597f959085643e50247651bf48fceff4bf1098b68cf47dae68f30173e45585bfdbf7126959387427a
+EBUILD tty-prompt-0.19.0.ebuild 604 BLAKE2B 8c3cf65b0b1eda1e552d9b223a4a5b5650e8db850ad38acb552fbcef943e59ddc16a76560a7cbdd0cdd38117b8c714ddfc7f93b1dd408f8b11849e8901daa52b SHA512 aadf2eb5360be2d5bb104c0f9a6edd0a37a33a3a0d6fa2b45c02c1aa8be1ea9fbd5c24994255fba78f1e03fe65959458b0e951bcb09b5b79770d165a628d33cb
+MISC metadata.xml 338 BLAKE2B 6162c739121dfed6f95cefbcd4b187668bcc434678ed094b70d9963662ab44e263e357ed1c3ad51bde318509dd19dabb7e8acd26845bfc1bad1119d2a6c27964 SHA512 383567b446b991c346809d57da8c2dc269d5dee34abc0a7ec354942ac025fc868cd0d2b92ebb764d7d2aa8a4b0f86ecc5bf00c80619922cb694fe0e04445d12b
diff --git a/dev-ruby/tty-prompt/metadata.xml b/dev-ruby/tty-prompt/metadata.xml
new file mode 100644
index 000000000000..a2602b5574e6
--- /dev/null
+++ b/dev-ruby/tty-prompt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piotrmurach/tty-prompt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild
new file mode 100644
index 000000000000..9e021c8b536c
--- /dev/null
+++ b/dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A beautiful and powerful interactive command line prompt"
+HOMEPAGE="https://github.com/piotrmurach/tty-prompt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/necromancer-0.5*
+ =dev-ruby/pastel-0.7*
+ =dev-ruby/tty-reader-0.6*
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}