summaryrefslogtreecommitdiff
path: root/dev-ruby/tins/tins-1.33.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tins/tins-1.33.0.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.33.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.33.0.ebuild b/dev-ruby/tins/tins-1.33.0.ebuild
new file mode 100644
index 000000000000..49ef1e3e0fb7
--- /dev/null
+++ b/dev-ruby/tins/tins-1.33.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/bigdecimal dev-ruby/sync"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}