summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt/tilt-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tilt/tilt-2.1.0.ebuild')
-rw-r--r--dev-ruby/tilt/tilt-2.1.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/tilt/tilt-2.1.0.ebuild b/dev-ruby/tilt/tilt-2.1.0.ebuild
deleted file mode 100644
index 4e2ad228cc46..000000000000
--- a/dev-ruby/tilt/tilt-2.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
-
-RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
-HOMEPAGE="https://github.com/jeremyevans/tilt"
-SRC_URI="https://github.com/jeremyevans/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-# Block on some of the potential test dependencies. These dependencies
-# are optional for the test suite, and we don't want to depend on all of
-# them to facilitate keywording and stabling.
-ruby_add_bdepend "test? (
- dev-ruby/erubi
- dev-ruby/nokogiri
-)"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
-
- # Avoid tests with minor syntax differences since this happens all
- # the time when details in the dependencies change.
- rm -f test/tilt_sasstemplate_test.rb || die
-
- # Skip tests for unpackaged asciidoctor converter
- sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
-}