summaryrefslogtreecommitdiff
path: root/dev-ruby/stringio/stringio-3.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stringio/stringio-3.0.9.ebuild')
-rw-r--r--dev-ruby/stringio/stringio-3.0.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/stringio/stringio-3.0.9.ebuild b/dev-ruby/stringio/stringio-3.0.9.ebuild
new file mode 100644
index 000000000000..e9ef6cc8a7cf
--- /dev/null
+++ b/dev-ruby/stringio/stringio-3.0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTENSIONS=(ext/stringio/extconf.rb)
+RUBY_FAKEGEM_GEMSPEC="stringio.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pseudo IO class from/to String."
+HOMEPAGE="https://github.com/ruby/stringio"
+SRC_URI="https://github.com/ruby/stringio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -e "/s.version =/ s/source_version/'${PV}'/" \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}