summaryrefslogtreecommitdiff
path: root/dev-ruby/stomp/stomp-1.4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stomp/stomp-1.4.8.ebuild')
-rw-r--r--dev-ruby/stomp/stomp-1.4.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/stomp/stomp-1.4.8.ebuild b/dev-ruby/stomp/stomp-1.4.8.ebuild
new file mode 100644
index 000000000000..6564bcdb89c1
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.4.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Skip specs that hang the test run indefinitely, most likely
+ # because of rspec-mocks deprecation output
+ rm -f spec/connection_spec.rb || die
+}