summaryrefslogtreecommitdiff
path: root/dev-ruby/set/set-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/set/set-1.0.1.ebuild')
-rw-r--r--dev-ruby/set/set-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/set/set-1.0.1.ebuild b/dev-ruby/set/set-1.0.1.ebuild
new file mode 100644
index 000000000000..2ca245abc0f2
--- /dev/null
+++ b/dev-ruby/set/set-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="set.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a class to deal with collections of unordered, unique values"
+HOMEPAGE="https://github.com/ruby/set"
+SRC_URI="https://github.com/ruby/set/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}