summaryrefslogtreecommitdiff
path: root/dev-ruby/serialport/serialport-1.3.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/serialport/serialport-1.3.2-r1.ebuild')
-rw-r--r--dev-ruby/serialport/serialport-1.3.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/serialport/serialport-1.3.2-r1.ebuild b/dev-ruby/serialport/serialport-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..2825b5e4e88f
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.3.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/native/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="https://github.com/hparra/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16-build-fix.patch
+)
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc test/miniterm.rb
+}