summaryrefslogtreecommitdiff
path: root/dev-ruby/serialport/serialport-1.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/serialport/serialport-1.3.1.ebuild')
-rw-r--r--dev-ruby/serialport/serialport-1.3.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/serialport/serialport-1.3.1.ebuild b/dev-ruby/serialport/serialport-1.3.1.ebuild
deleted file mode 100644
index bd32e9c0411f..000000000000
--- a/dev-ruby/serialport/serialport-1.3.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="a library for serial port (rs232) access in ruby"
-HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-all_ruby_prepare() {
- # Fix the miniterm script so that it might actually work, we'll
- # install it as example.
- sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
-}
-
-each_ruby_configure() {
- cd ext/native || die
- ${RUBY} extconf.rb || die
-}
-
-each_ruby_compile() {
- pushd ext/native &>/dev/null
- emake V=1
- popd &>/dev/null
-
- # Avoids the need for a specific install phase
- cp ext/native/*$(get_modname) lib/ || die "extension copy failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc test/miniterm.rb
-}