summaryrefslogtreecommitdiff
path: root/dev-ruby/sawyer/sawyer-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/sawyer/sawyer-0.9.2.ebuild')
-rw-r--r--dev-ruby/sawyer/sawyer-0.9.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/sawyer/sawyer-0.9.2.ebuild b/dev-ruby/sawyer/sawyer-0.9.2.ebuild
new file mode 100644
index 000000000000..9c8c0ddd5aec
--- /dev/null
+++ b/dev-ruby/sawyer/sawyer-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="sawyer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Secret User Agent of HTTP"
+HOMEPAGE="https://github.com/lostisland/sawyer"
+SRC_URI="https://github.com/lostisland/sawyer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+ruby_add_rdepend "
+ <dev-ruby/faraday-3:*
+ >=dev-ruby/addressable-2.3.5
+"
+
+all_ruby_prepare() {
+ # Avoid tests that require network access
+ sed -i -e '/test_blank_response_doesnt_raise/,/^ end/ s:^:#:' test/agent_test.rb || die
+}