summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-termios/ruby-termios-1.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-termios/ruby-termios-1.1.0-r1.ebuild')
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-1.1.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/ruby-termios/ruby-termios-1.1.0-r1.ebuild b/dev-ruby/ruby-termios/ruby-termios-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..62fded4f986e
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-1.1.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md termios.rd"
+
+# There are no tests in the gem, and the upstream tests only work
+# with a normal TTY, bug 340575.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+IUSE=""