summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest2
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.7.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index 3b027450a76a..2250ccc432a0 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,3 +1,5 @@
DIST ruby-prof-1.7.0.tgz 251253 BLAKE2B e9cc60591d5cb8b3be528ba57c6374e7965b2f23394d468f3eb62a547e50edc7cc4ea99a6985726a30f063a0ce4823863b468e0ef2c89ef58cfbbe0362bfdb96 SHA512 ecea55a2a77d832f4aeca73aab578372a57a4fdf2cfc4db1fb14a899fed35ddfac79a078ab8207af8a4e70cdd0c4bb1e44a9ead8642e06b27ac4214d7d5981ef
+DIST ruby-prof-1.7.1.tgz 251300 BLAKE2B ad2e995280f466605fd09aab89eae473bcf5163860bd3cf2df640b8e7ae72ae978aae366c921bed22698ec81030986be1b8d6a0d5baf8a55b5bedef400de3429 SHA512 4cd849b1f26844edd89e2a962bdc2e229d834c1d79012ed26672be1f8dfb4f0056a9177c8df77a2ab44f1de3991229f03a8d185c34d7c25ef85b48652560d4bf
EBUILD ruby-prof-1.7.0.ebuild 1219 BLAKE2B 820b12d02de757fe738a98f8160db359b938080f3169466965da20e63b04e7854a3bfdf12cc375988a14a7a8c274e9fac1873930b197bc23384a05d1d9290315 SHA512 b3fb2206f85b4bb253898a6a54ab6f75dac4ab7d28c5df8b42580e3f807b744bffb37637fe24d58cdfeb148c4dff50e308bd2d1aa606eaa4c16bb656f5e9273b
+EBUILD ruby-prof-1.7.1.ebuild 1223 BLAKE2B 632aa385b35a408f7cfda64a152049740c161e033bcade94295f4e8e9fe52594e877ab8d184b3162a0cff03460a4febcf44202313f90b18b21dd7d62d17fa2a9 SHA512 ede1a1e9d452301227b4dce57e0544ef7ec789943531a5f35efdb7d4856c6cf7bbefe3720e22f3eb0c832b02bd52b3cbdbe8d30a892afad03c3f72b74cc17521
MISC metadata.xml 346 BLAKE2B 245dc508fb9933ff6a69b4e7c8a516ac9bb237798680ae70a8fbaeb57481520760f5a17a62cb045f82a955e0fc882fd84fb60d17b68bec1180b386355ca6b6fd SHA512 2cb1d6e31ac399f7faceccfd9dcc5e1a1e29bc10596ba3e0b3960ecc2bc215b21d351611e3ab6bfe7451fcee3bd4880a229b8266b7c8f6321bc79bdd5109b5d9
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.7.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.7.1.ebuild
new file mode 100644
index 000000000000..b98c8311d4e5
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-1.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_prof/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Don't strip library by default
+ sed -i -e '/LDFLAGS/ s/-s//' ext/ruby_prof/extconf.rb || die
+}