summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ole/ruby-ole-1.2.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-ole/ruby-ole-1.2.13.1.ebuild')
-rw-r--r--dev-ruby/ruby-ole/ruby-ole-1.2.13.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ole/ruby-ole-1.2.13.1.ebuild b/dev-ruby/ruby-ole/ruby-ole-1.2.13.1.ebuild
new file mode 100644
index 000000000000..e688f3070f8d
--- /dev/null
+++ b/dev-ruby/ruby-ole/ruby-ole-1.2.13.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+# Same thing for the docs whose rake target just calls rdoc.
+RUBY_FAKEGEM_RECIPE_DOC=rdoc
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for easy read/write access to OLE compound documents"
+HOMEPAGE="https://github.com/aquasync/ruby-ole"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --pattern='test.*\.rb' test/
+}