summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-3.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rouge/rouge-3.3.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.3.0.ebuild b/dev-ruby/rouge/rouge-3.3.0.ebuild
new file mode 100644
index 000000000000..1edff6ffcae4
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+#SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet
+ !!<dev-ruby/rouge-1.11.1-r2:0"
+
+RESTRICT="test"
+# Depends on dev-ruby/minitest-power_assert, which is not packaged yet.