summaryrefslogtreecommitdiff
path: root/dev-ruby/rbnacl/rbnacl-4.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rbnacl/rbnacl-4.0.2-r1.ebuild')
-rw-r--r--dev-ruby/rbnacl/rbnacl-4.0.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/rbnacl-4.0.2-r1.ebuild b/dev-ruby/rbnacl/rbnacl-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..8501b10c9e7f
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-4.0.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/cryptosphere/rbnacl"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-libs/libsodium"
+DEPEND+=" test? ( dev-libs/libsodium )"
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+PATCHES=( "${FILESDIR}/rbnacl-buffer-size.patch" )
+
+all_ruby_prepare() {
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
+}