summaryrefslogtreecommitdiff
path: root/dev-ruby/rack/rack-2.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack/rack-2.0.9.ebuild')
-rw-r--r--dev-ruby/rack/rack-2.0.9.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/rack/rack-2.0.9.ebuild b/dev-ruby/rack/rack-2.0.9.ebuild
deleted file mode 100644
index 61f526b24039..000000000000
--- a/dev-ruby/rack/rack-2.0.9.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.rdoc SPEC"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="https://rack.github.com/"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/minitest-global_expectations
- dev-ruby/concurrent-ruby
-)"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.5.2-r4:1.5 !<dev-ruby/rack-1.6.4-r2:1.6"
-
-all_ruby_prepare() {
- # The build system tries to generate the ChangeLog from git. Create
- # an empty file to avoid a needless dependency on git.
- touch ChangeLog || die
-
- # Avoid development dependency
- sed -i -e '/minitest-sprint/ s:^:#:' rack.gemspec || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e "require 'test/gemloader.rb'; Dir['test/spec_*.rb'].each{|f| require f}" || die
-}