summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection/rack-protection-3.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack-protection/rack-protection-3.0.1.ebuild')
-rw-r--r--dev-ruby/rack-protection/rack-protection-3.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/rack-protection-3.0.1.ebuild b/dev-ruby/rack-protection/rack-protection-3.0.1.ebuild
new file mode 100644
index 000000000000..d31bdbd997d7
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-3.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"