summaryrefslogtreecommitdiff
path: root/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild
new file mode 100644
index 000000000000..a7f2b53b2dde
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}